GPAS-Zeiterfassung

GPAS: Hilfe | Zeiterfassung | Rel. 1.01
Artemis |  |

Die Zeiterfassung ermöglicht im Wesentlichen zwei Dinge:

  • die genaue Zeitnahme der tatsächlichen Arbeitszeit aller MitarbeiterInnen und
  • zeigt in einer Übersicht, ob MitarbeiterInnen an- oder abwesend sind.

    • Das Programm besteht aus drei Teilen:

  • An- und Abmelden
  • wer ist anwesend und
  • das eigentliche Programm mit Parametern, Kalender- und Personalstamm und Arbeitszeiten.

    • Haben Sie Fragen oder Wünsche, können Sie uns erreichen per:
    Telefon: | +49 40 340973
Fax: | +49 40 340974
E-mail: | info@gpas.de
Internet: | www.gpas.de

    Es handelt sich um ein Produkt der Firma

    Gesellschaft für Projektberatung und Anwendungs-Software

    © GPAS mbH 1983-2o1o


Programmstart

Artemis | Programmstart | Rel. 1.25

Der Start des Programms erfolgt über das einzig ausführbare Programm in der Anwendung: "aHORA.exe".
Der Name setzt sich zusammen aus dem Anfangsbuchstaben (damit das Programm gleich vorm in Verzeichnis zu sehen ist) und dem Kürzel der Anwendung.
Es kann mit weiteren Parametern aufgerufen werden, denen ein "/" vorangestellt ist:

  • 1. dem Bedienerkürzel,
  • 2. der Firma,
  • 3. dem Programmparameter,
  • 4. dem Schlüssel für die Anpassung an die Bildschirmauflösung.

    • Der Programmparameter kann folgenden Inhalt haben:

  • /A = Anwesende
  • /B = Backgroundmanager
  • /L = Login (An- und Abmelden) und
  • /O = Operating-Menü.

    • Der Parameter für die Anpassung an die Bildschirmauflösung dient der besseren Darstellung auf unterschiedlichen Monitoren. Die Programme sind optimiert für eine Auflösung von 1024x768. Die Darstellung auf einem Breitbandmonitor beispielsweise verzerrt die Anzeige in der Horizontalen. Durch Vorgabe eines Wertes zwischen 1 und 99 kann die Darstellung angepasst werden.

    Eine Verknüfung auf dem Desktop (siehe Installation) ist wohl die beste Methode, das Programm zu starten.

    Nach Start des Programms wird der Anmeldebildschirm (Login) aufgeblendet.

    Bildschirm: Login

    Die Anmeldung erfolgt über eine "User-Id" und optional einem Passwort.
    Die "User-Id" oder das Mitarbeiterkürzel muss im Benutzerstamm angelegt sein, sonst wird die Anmeldung mit einer entsprechenden Fehlermeldung zurückgewiesen.

    Ist das Passwort nicht o.k., wird gleichfalls eine Meldung erzeugt. Nach dreimaligem Fehlversuch wird der Bildschirm eingefroren. Auch nach erneutem Start ist dann keine Anmeldung möglich. Ist die Anmeldeprozedur erfolgreich, wird auf den nächsten Bildschirm verzweigt.

    Bildschirm: Firma/Geschäftsjahr

    Hier wird die Firma und das Geschäftsjahr verlangt, unter dem man sich anmelden will.

    Hierfür gibt es drei Voraussetzungen:

  • Für die Firma muss ein Firmenstammsatz (siehe Operating-Menü: Firmenstammsatz) vorhanden sein.
  • Ebenso müssen die Datenverzeichnisse erstellt sein (Operating-Menü: Datei- und Verzeichnisanlage)).
  • Für die Firma muss ein Basisparameter vorhanden sein.

    • Der Basisparameter kann bei erstmaligem Einstieg nur angelegt werden, wenn eine Operatorberechtigung (siehe Operating-Menü: Benutzerberechtigung) besteht.

    Hinweis: Nach der Neuinstallation existiert kein Basisparameter.
    Der Basisparameter kann bei erstmaligem Einstieg nur angelegt werden, wenn eine Operatorberechtigung (siehe Operating-Menü: Benutzerberechtigung) besteht.
    Bei entsprechender Berechtigung muss die Frage, ob der Parameter angelegt werden soll, mit 'Ja' beantwortet werden. Danach kann in das Hauptmenü verzweigt werden.
    Dort muss zuerst das Programm Anwendung sperren/freigeben aufgerufen werden, um die Anwendung freizugeben.
    Dann bitte die Basisparameter pflegen.


Hauptmenü

Artemis | Hauptmenü | Rel. 1.25

Nach erfolgreicher Anmeldung befindet man sich im zentralen Hauptmenü.

Bildschirm: Hauptmenü

Das Hauptmenü besteht aus verschiedenen Teilen:

  • der Titelzeile mit dem Programmsymbol oben links, der Titelzeile (Firmenname) und den 3 Buttons rechts zum Minimieren, Wiederherstellen und Beenden des Programms;
  • der Menübar mit allen verfügbaren Programmen innerhalb des Paketes,
  • der Toolbar mit Symbolen ausgewählter Programme,
  • dem Mittelteil mit einem austauschbaren Bild und
  • der Statuszeile

    • Aus dem Hauptmenü heraus werden alle weiteren Programme aufgerufen.
    Ein Programm kann über die Menübar oder durch Eingabe der Programm-Nr. oben rechts aufgerufen werden.

    Der Mittelteil beginnt mit einer Meldungszeile, in der beispielsweise ein verfügbares Update eingeblendet wird, sofern die Berechtigung für die Updatefunktion den Wert 4 enthält. Oder ein individueller Text, der im Programm allg. Hinweise u. Meldungen unter PNr. 0000 und lfd.Nr. 9999 gepflegt werden kann.

    Das Bild im Mittelteil kann gegen ein anderes Bild ausgetauscht werden. Dazu benennen Sie ihr Bild in "hora.jpg" und kopieren es in den Programmpfad. Dabei müssen Sie die vorhandene Datei überschreiben.

    Im unteren Teil des Bildschirms dient die Statusbar im linken Teil zur Anzeige einer laufenden Information als Text, im rechten Teil zur Anzeige von Konstanten, beginnend mit

  • dem Einfügemodus (Anzeige: INS oder leer),
  • dem Groß-/Kleinmodus (Anzeige: CAPS oder leer),
  • dem Ziffernmodus (Anzeige: NUM oder leer),
  • der Firma und dem Geschäftsjahr und
  • dem aktuellen Datum und der Zeit im Minutentakt.


Parameter

Artemis | Basisparameter | Rel. 1.25

Nach Aufruf des Programms wird auf das Parametermenü verzweigt, von dem aus die einzelnen Parameter aufgerufen werden:

Bildschirm: div. Parameter

Basisparameter

Zuerst muss der Basisparameter mit Namen und Anschrift der Firma vorhanden sein.

Bildschirm: Basisparameter

Der Kurzname wird im Hauptmenü in die Titelzeile übernommen.

Feiertage

Bildschirm: Feiertage

An Feiertagen werden nur die nationalen bzw. gesetzlichen Feiertage eingetragen, z. B.:

  • Neujahr,
  • Tag der Arbeit,
  • Tag der Deutschen Einheit

    • Die kirchlichen Feiertage:

  • Hl. 3 Könige
  • Karfreitag,
  • Ostern,
  • Christi Himmelfahrt
  • Pfingsten,
  • Fronleichnam,
  • Buß- und Bettag
  • Weihnachten

    • werden vom Programm gesetzt.
    Die Berechnung der veränderlichen Feiertage (Ostern) erfolgt anhand der Formel des Mathematikers Carl Friederich Gauss (1777-1805).

    Namen und Abkürzungen der Monate

    Bildschirm: Parameter Monate

    Hier werden die Namen und Abkürzungen der Monate gespeichert.
    Ist dieser Parameter nicht vorhanden, wird mit den im Bildschirmausdruck gezeigten Namen gearbeitet.

    Namen und Abkürzungen der Wochentage

    Bildschirm: Parameter Wochentage

    Hier werden die Namen und Abkürzungen der Wochentage gespeichert.
    Ist dieser Parameter nicht vorhanden, wird mit den im Bildschirmausdruck gezeigten Namen gearbeitet.

    Funktionen

    Im Programm stehen folgende Funktionen zur Verfügung:

    Symbol | Taste | Funktion
 | Enter | ausführen
 |  | Reset
 | F1 | Hilfe
 | Esc | Ende


Kalender

Artemis | Jahreskalender | Rel. 1.25
.gif

Die Jahresübersicht besteht aus einer Kombination des Jahreskalenders, den Daten aus dem Personalstamm und den Arbeitszeitdaten.

Bildschirm: Jahreskalender

Ist das Feld "MitarbeiterIn" nicht gefüllt, werden die allgemeinen Daten für das entsprechende Kaledenderjahr angezeigt, sonst die Mitarbeiterdaten.

Für den Mitarbeiter muss im Personalstamm ein Stammsatz angelegt sein.

Im oberen Bildschirmteil besteht die Tabelle horizontal aus den Monaten 1-12 und vertikal aus den:

  • Arbeitstagen des Jahres,
  • arbeitsfreien und Feiertagen,
  • Urlaubstagen,
  • Sonderurlaubstagen,
  • Krankheitstagen,
  • Fehlzeiten,
  • Wintertagen und
  • Kalendertagen.

    • Der untere Bildschirmteil ist unterteilt. Rechts werden die Daten eines Monats angezeigt, links können Daten verändert werden.

    Die veränderbaren Daten sind klassifiziert nach:

  • A = Arztbesuch,
  • B = Berufsschule,
  • C = krankes Kind,
  • F = Feiertag bzw. frei (Wochenende),
  • G = Gericht,
  • K = krank,
  • S = Sonderurlaub und
  • U = Urlaub.

    • Die Daten können in der Rubrik "Eingaben" angewählt und verändert (gespeichert oder gelöscht) werden.

    In der Rubrik "Urlaub" wird der Urlaubsanspruch dem Personalstamm entnommen und kann nicht überschrieben werden.
    In der Rubrik "Überstunden" ergeben sich die geleisteten Stunden aus den Arbeitszeiten. Hier werden als Veränderung die vergüteten Stunden eingetragen.

    Die vorgenommenen Veränderungen werden formal geprüft. So werden z.B. keine Stunden > 24 und keine Minuten > 59 akzeptiert.

    Funktionen

    Im Programm stehen folgende Funktionen zur Verfügung:

    Symbol | Taste | Funktion
 | F4 | vorheriger Datensatz
 | F5 | dieser Datensatz
 | F6 | nächster Datensatz
 | Enter | Daten prüfen
 | Strg + S | Daten speichern
 | Strg + D | Daten löschen
 |  | Reset
 | F1 | Hilfe
 | Esc | Ende


Personalstamm

Artemis | Personalstamm | Rel. 1.25

Im Personalstamm werden sowohl die allgemein gültigen Arbeits- und Pausenzeiten als auch die besonderen Zeiten je MitarbieterIn festgehalten.

Bildschirm: Personalstamm

Ist das Feld "MitarbeiterIn" leer, gelten die Daten allgemein, sonst für den jeweiligen Mitarbeiter.
Dabei werden die Daten datumsabhängig (Feld: "gültig ab") gespeichert. Somit können im Laufe der Zeit verschiedene Parameter angelegt werden.

Im Programm stehen folgende Funktionen zur Verfügung:

Symbol | Taste | Funktion
 | Enter | ausführen
 |  | Reset
 | F1 | Hilfe
 | Esc | Ende


Umgliedern MitarbeiterIn

Artemis | Umgliedern MitarbeiterIn | Rel. 1.25
Bildschirm: Umgliedern MitarbeiterIn

MitarbeiterInnen werden über das Mitarbeiterkürzel identifiziert. Das Kürzel ist zugleich Satzschlüssel in den Daten der Zeiterfassung. Ändert sich nun der Name, wird oft ein neues Kürzel gewünscht und vergeben.

In diesem Programm erfolgt die Umgliederung der aller Daten der Zeiterfassung vom alten auf das neue Kürzel.

Funktionen

Im Programm stehen folgende Funktionen zur Verfügung:

Symbol | Taste | Funktion
 | Enter | ausführen
 |  | Reset
 | F1 | Hilfe
 | Esc | Ende


Urlaubsübersicht

Artemis | Urlaubsübersicht | Rel. 1.25
Bildschirm: Urlaubsübersicht

Die Urlaubsübersicht zeigt für alle Monate oder in der Auswahl von-bis Monat je MitarbeiterIn den eingetragenen Urlaub.

Funktionen

Im Programm stehen folgende Funktionen zur Verfügung:

Symbol | Taste | Funktion
 | Enter | ausführen
 |  | Reset
 | F1 | Hilfe
 | Esc | Ende


Korrektur Arbeitszeit

Artemis | Korrektur Arbeitszeit | Rel. 1.25
Bildschirm: Korrektur Arbeitszeit

Hier können die Arbeitszeiten korrigiert werden, wenn z. B. die An-, Abmeldung oder Pause vergessen wurde.
Ein bestehender Datensatz wird durch Doppelklick ausgewählt. Dabei werden Datum, Arbeitsbeginn und -ende in den oberen Teil des Bildschirms kopiert, können geändert und neu abgespeichert oder gelöscht werden.
Werden Daten geändert oder neu angelegt, erfolgt eine formale Prüfung auf die Felder Datum, Arbeitsbeginn und -ende. Fehlerhafte Daten werden zurückgewiesen.

Mit den Symbolen im unteren linken Bildschirm kann vor- und rückwärts geblättert werden, wobei jeweils die Daten des vorherigen/nächsten Mitarbeiters angezeigt werden. Durch Eingabe eines Mitarbeiterkürzels und Betätigen der F6-Taste oder des entsprechenden Symbols werden die Daten des gewünschten Mitarbeiters angezeigt.

Funktionen

Im Programm stehen folgende Funktionen zur Verfügung:

Symbol | Taste | Funktion
 | F4 | vorheriger Datensatz
 | F5 | dieser Datensatz
 | F6 | nächster Datensatz
 | Enter | Daten prüfen
 | Strg + S | Daten speichern
 | Strg + D | Daten löschen
 |  | Reset
 | F1 | Hilfe
 | Esc | Ende


Aktualisieren Überstunden

Artemis | Aktualisieren Überstunden | Rel. 1.25

Das Programm listet und überträgt ggf. die geleisteten Überstunden eines Monats.

Bildschirm: Aktualisieren Überstunden

Der Zeitraum bestehend aus Monat und Jahr muss angegeben werden.

Erfolgt in den Feldern 'MitarbeiterIn von...bis...' keine Eingabe, erfolgt die Verarbeitung für alle MitarbeiterInnen, sonst nur für die innerhalb des Bereiches von/bis. Soll nur für eine Person gearbeitet werden, reicht die Eingabe im Feld 'von'.

Die Aktualisierung der Überstunden erfolgt nur, wenn die Checkbox "Überstunden" aktualisieren aktiv gesetzt ist. Ansonsten werden lediglich die Daten gelistet.

Funktionen

Im Programm stehen folgende Funktionen zur Verfügung:

Symbol | Taste | Funktion
 | Enter | ausführen
 |  | Reset
 | F1 | Hilfe
 | Esc | Ende


Jahreswechsel

Artemis | Jahreswechsel | Rel. 1.25
Bildschirm: Jahreswechsel

Der Jahreswechsel hat zwei Funktionen:

  • Parameter für das Folgejahr bereitstellen und
  • Kalenderdaten der MitarbeiterInnen für das Folgejahr abstellen.

    • Die Daten werden einmalig - unabhängig, wie oft das Programm aufgerufen wird - bereitgestellt.

    Der endgültige Jahreswechsel sperrt den weiteren Aufruf des Programms.

    Funktionen

    Im Programm stehen folgende Funktionen zur Verfügung:

    Symbol | Taste | Funktion
 | Enter | ausführen
 |  | Reset
 | F1 | Hilfe
 | Esc | Ende


Druck Arbeitszeit

Artemis | Druck Arbeitszeit | Rel. 1.25

Das Program listet die Arbeitszeiten der Mitarbeiter(Innen) eines bestimmten Monats.

Bildschirm: Druck Arbeitszeit

Als Ausgabe stehen zur Auswahl:

  • Textdatei,
  • PDF-Dokument,
  • Printfile,
  • html (Internet) und
  • Tabellenkalkulation.

    • Funktionen

    Im Programm stehen folgende Funktionen zur Verfügung:

    Symbol | Taste | Funktion
 | Enter | ausführen
 |  | reset
 | F1 | Hilfe
 | Esc | Ende


Druck Kalender

Artemis | Druck Kalender | Rel. 1.25

Das Program listet den Kalender der Mitarbeiter(Innen) eines bestimmten Jahres zuzüglich der Kalenderdaten ausgewählter Monate.

Bildschirm: Druck Übersicht

Funktionen

Im Programm stehen folgende Funktionen zur Verfügung:

Symbol | Taste | Funktion
 | Enter | ausführen
 |  | reset
 | F1 | Hilfe
 | Esc | Ende


Programmverzeichnis

Artemis | Programmverzeichnis | Rel. 1.25
Programm | Funktion
9991 | An- und Abmelden
9992 | Anwesende
0001 | Hilfsprogramme
0003 | Datenverweis
0004 | E-Mail
0007 | Passwortpflege
0008 | Anwendung sperren/freigeben
0011 | Lizenz
0013 | Info Konfiguration
0015 | Auswahlkriterien löschen
0017 | Meldungen und Fehlertexte
0019 | aktive MitarbeiterInnen
0097 | Backgroundmanager
0110 | Aufruf Bach
0982 | Anzeige print-Dokumente
0984 | Anzeige htm-Dokumente
0986 | Anzeige txt-Dokumente
0988 | Anzeige pdf-Dokumente
1010 | Parameter
1020 | Jahreskalender
2010 | Personalstamm
2020 | Umgliedern Mitarbeiter
2050 | Urlaubsübersicht
3710 | Korrektur Arbeitszeit
3720 | Aktualisieren Überstunden
4160 | Jahrewechsel
8110 | Druck Kalender
8120 | Druck Arbeitszeiten
9997 | Update
9999 | Operating-Menü
mand | Mandantenstammsatz
benu | Benutzerberechtigung
file | Datei- u. Verzeichnisanlage
reog | Reorganisieren Dateien


GPAS(Hamburg) Funktions-Grafik

GPAS: Hilfe | Funktionssymbole | Rel. 1.01

Eine Programmfunktion wird per Klick auf ein Symbol oder die damit verbundene Funktionstaste auf der Tastatur ausgelöst. Die Symbole und deren allgemeine Funktion sind hier dargestellt.

Nr. | Symbol | Bedeutung
00 |  | los geht's, starten, ausführen
01 |  | Löschen
02 |  | Drucken
03 |  | Ausschneiden
04 |  | Kopieren
05 |  | Einfügen
06 |  | Anzeigen
07 |  | Aktualisieren
08 |  | Sortieren (absteigend)
09 |  | Sortieren (aufsteigend)
10 |  | Startseite
11 |  | Reorganisieren
12 |  | Import
13 |  | Export
14 |  | BS-Druck
16 |  | Ende
19 |  | Summe
20 |  | neu
21 |  | zurück
22 |  | vor
23 |  | o. k., weiter, ...
27 |  | in- /reaktivieren
28 |  | Auswahl abspeichern
29 |  | Storno
31 |  | Zentrieren
32 |  | Stop
33 |  | Weiter geht's
34 |  | Suchen
35 |  | neu
39 |  | Auf-/Abschlag
40 |  | nächster Satz
41 |  | vorheriger Satz
42 |  | nächster Satz mit Daten
43 |  | vorheriger Satz mit Daten
44 |  | letzter Satz
45 |  | erster Satz
46 |  | Jahr +1
47 |  | Jahr -1
48 |  | Verkleinern
49 |  | Vergrößern
50 |  | Stammdaten
60 |  | Kontenanzeige
61 |  | Beleganzeige
62 |  | Offene Posten
63 |  | Saldenanzeige
64 |  | aktueller Buchungsstand
65 |  | Budget
66 |  | Kontokorrentinfo
67 |  | Memorandum
68 |  | Beleg/Rechnung suchen
69 |  | Landes-/Fremdwährung
89 |  | Datei öffnen
90 |  | Zugriff auf Programme (Charakter-Oberfläche)
91 |  | Alles abwählen
92 |  | Alles auswählen
97 |  | Reset
98 |  | Hilfe
99 |  | Ende


An- und Abmelden

Artemis | An- und Abmelden | Rel. 1.25

Dieses Programm dient zur Erfassung der Arbeitszeiten je MitarbeiterIn.

Nach Start des Programms wird der Anmeldebildschirm (Login) aufgeblendet.

Bildschirm: Login

Die Anmeldung erfolgt über eine "User-Id" und optional einem Passwort.
Die "User-Id" oder das Mitarbeiterkürzel muss im Benutzerstamm angelegt sein, sonst wird die Anmeldung mit einer entsprechenden Fehlermeldung zurückgewiesen.

Ist das Passwort nicht o. k., wird gleichfalls eine Meldung erzeugt. Nach dreimaligem Fehlversuch wird der Bildschirm eingefroren. Auch nach erneutem Start ist dann keine Anmeldung möglich. Ist die Anmeldeprozedur erfolgreich, wird auf den Anmeldebildschirm verzweigt.

Bildschirm: An- und Abmelden

Es kennt die Funktionen:

  • An- und
  • Abmelden

    • Bei Arbeitsbeginn bietet das Programm die Funktion "Anmelden", die Funktion "Abmelden" ist nicht ausführbar.. Bei Programmstart wird die aktuelle Zeit genommen und als Arbeitsbeginn festgehalten. Mit der Enter-Taste wird diese Zeit in die Arbeitszeitdatei übernommen.

    Bei erneutem Programmaufruf wird die Funktion "Abmelden" bereitgestellt. Jetzt ist die Funktion "Anmelden" nicht möglich. Zum "Abmelden" muss ein Grund genannt sein:

  • Pause oder
  • Feierabend

    • Ist die Auswahl getroffen, wird die Arbeitsunterbrechung bzw. das Arbeitsende in die Arbeitszeitdatei übernommen.

    Rechts oben sind die bis zum lfd. Tag aufgelaufenen Arbeitsstunden (durchschnittliche Sollstunden vom Monatsanfang bis zum lfd. Tag und tatsächliche Iststunden vom Monatsanfang bis zum Vortag) des lfd. Monats aufgeführt. Der lfd. Tag selbst ist im Mittelteil rechts mit Anfangszeit, Pausen, Unterbrechung und Arbeitsende dokumentiert.

    Der Text in der Rubrik 'Willkommen' entspricht den Meldungs-Nr. 10 (anmelden) und 11 (abmelden) im Programm Meldungen und Fehlertexte und können dort an die eigenen Bedürfnisse angepasst werden.

    Hinweis: Beim Anmelden wir die Zeit zum Zeitpunkt des Programmstarts genommen, nicht die beim Betätigen des Buttons 'Anmelden'! Beim Abmelden wird die Zeit zum Zeitpunkt des Programmendes gespeichert.

    Funktionen

    Im Programm stehen folgende Funktionen zur Verfügung:

    Symbol | Taste | Funktion
 | Enter | Anmelden: Beginn bzw. Fortsetzen der Arbeitstätigkeit
 | Enter | Abmelden: Ende bzw. Unterbrechung der Arbeitstätigkeit
 | F1 | Hilfe
 | Esc | Ende
 |  | Kalender: Verzweigen auf die Kalenderdaten mit Anzeige der Arbeits- Urlaubs- und Fehlzeiten sowie ev. Überstunden.


Anwesende MitarbeiterInnen

Artemis | Anwesende | Rel. 1.25

Dieses Programm zeigt, welche MitarbeiterInnen sich im Büro befinden, wer zur Pause ist, bereits Feierabend hat oder gar nicht im Hause war.

Die Anzeige wird je Minute aktualisiert.

Bildschirm: Anwesende

Die Anwesenheit ist durch den Haken vor dem Namen und der grünen Farbe deutlich gekennzeichnet.

Hat keine Anmeldung im Laufe des Tages stattgefunden, bleibt der Name grau, während der Pause weiß und nach Feierabend rot.

Funktionen

Im Programm stehen folgende Funktionen zur Verfügung:

Symbol | Taste | Funktion
 |  | Reset
 | F1 | Hilfe
 | Esc | Ende

Die Funktion "Reset" löscht die Datei "Anwesend" im Arbeitsverzeichnis. Beim nächsten Intervall (default: 1 Minute) wird die Datei neu aufgebaut.